Link Branding Creation Fails with HTTP 500 Internal Server Error (Auto SSL Enabled)
Our engineers have monitored the fix and confirmed the issue with Link Branding (Auto SSL Enabled) has been resolved. All services are now operating normally at this time. (Affected: SendGrid Website)
Started
Sep 24, 2026, 4:22 PM UTC
Resolved
Sep 24, 2026, 6:26 PM UTC
Duration
2h 4m
Verified sources
Incident Detail
Starting at approximately 8:40am Pacific time on Sept 24th, our engineers have identified an issue causing HTTP 5xx errors during Link Branding creation with Auto SSL enabled and are working to deploy a fix. We expect to provide another update in 2 hours or as soon as more information becomes available.
Our engineers have implemented a fix and are monitoring system performance. Link Branding creation with Auto SSL selected has recovered and functionality has improved. We will provide another update in 30 minutes or as soon as more information becomes available.
Our engineers have monitored the fix and confirmed the issue with Link Branding (Auto SSL Enabled) has been resolved. All services are now operating normally at this time.